API Worx Accounting Integration down

Incident Report for Extensiv

Resolved

This incident has been resolved.
Posted Aug 21, 2025 - 12:40 PDT

Identified

Our upstream provider, API Worx, has identified the issue and is working on a fix. Based on their time estimate, we will provide another estimate within 2 hours.
Posted Aug 21, 2025 - 11:19 PDT

Investigating

Our upstream provider, API Worx, is currently experiencing an issue which is affecting our ability to export and sync invoices between Billing Manager and QuickBooks. Billing Manager users may be affected.

We will resolve this incident once we have received confirmation the issue has been resolved from the upstream provider. We will send an additional update in one hour.
Posted Aug 21, 2025 - 11:03 PDT
This incident affected: Platform (Billing Manager).