Invalid Request Error when creating labels through Stamps.com

Incident Report for Extensiv

Resolved

This incident has been resolved.
Posted Jul 31, 2025 - 07:29 PDT

Update

We are continuing to investigate this issue.
Posted Jul 31, 2025 - 06:43 PDT

Investigating

Our upstream provider, Stamps.com, is currently experiencing an issue which is affecting our ability to create USPS labels. Users who generate USPS labels using Stamps.com may be affected.

We will resolve this incident once we have received confirmation the issue has been resolved from our upstream provider. We will send an additional update in one hour.
Posted Jul 31, 2025 - 05:42 PDT
This incident affected: Platform (Small Parcel Suite).