Rate Shopping Slowness

Incident Report for Extensiv

Resolved

This incident has been resolved.
Posted Sep 19, 2025 - 11:53 PDT

Update

We are continuing to investigate this issue.
Posted Sep 19, 2025 - 05:40 PDT

Investigating

We are currently investigating intermittent slowness users may experience when rate shopping orders in Small Parcel. We are working to resolve this as soon as possible, but do not yet have an estimated timeline.
Posted Sep 18, 2025 - 13:06 PDT
This incident affected: Platform (Small Parcel Suite).