Customers receiving a 500 "something wrong" error.
Incident Report for Extensiv
Resolved
This incident has been resolved.
Posted Apr 17, 2024 - 05:35 PDT
Monitoring
We are currently monitoring an issue where users receive a 500 "Something Wrong" error when attempting to perform various functions. We believe this has been resolved but are monitoring for further instances.

If you receive this error, please refresh your browser.
Posted Apr 16, 2024 - 12:10 PDT
This incident affected: Platform (3PL Warehouse Manager).