Unable to create or save contacts in the Manage Contacts or Manage Supplier Module

Incident Report for Extensiv

Resolved

This incident has been resolved.
Posted Sep 18, 2023 - 20:49 PDT

Update

The fix will be implemented tonight, September 18th, 2023 @9PM Mountain time.
Posted Sep 18, 2023 - 10:19 PDT

Identified

The issue has been identified and a fix is being implemented.
Posted Sep 18, 2023 - 09:22 PDT
This incident affected: Platform (3PL Warehouse Manager).