Shipengine 504 error
Incident Report for Extensiv
Resolved
This incident has been resolved.
Posted Mar 08, 2024 - 16:49 PST
Monitoring
A fix has been implemented and we are currently monitoring the status.
Posted Mar 08, 2024 - 11:18 PST
Investigating
We have received reports of higher than expected latency when getting USPS rates via Stamps.com and Endicia carriers. This is currently being investigated by Shipengine.

https://status.shipengine.com/
Posted Mar 08, 2024 - 10:38 PST
This incident affected: Platform (Small Parcel Suite).