Reports of Lag and Slowness

Incident Report for Extensiv

Resolved

This incident has been resolved.
Posted Nov 03, 2025 - 12:13 PST

Monitoring

A fix has been implemented, and this should now be resolved. Our teams will continue to monitor.
Posted Nov 03, 2025 - 11:24 PST

Investigating

We have received reports of slowness and errors throughout Extensiv. Our teams are working to resolve this now. We will have an update for you in 30 minutes.
Posted Nov 03, 2025 - 11:20 PST
This incident affected: Platform (3PL Warehouse Manager, SmartPack, Small Parcel Suite, SmartScan).