Unable to ship using Amazon Buy Shipping

Incident Report for Extensiv

Resolved

This incident has been resolved.
Posted Jul 10, 2026 - 08:16 PDT

Monitoring

A fix has been implemented for the issue affecting the Amazon Buy Shipping service. We are actively monitoring the results to ensure the fix is performing as expected and that normal functionality has been fully restored. We will continue to provide updates as needed.
Posted Jul 09, 2026 - 16:01 PDT

Identified

We have identified the issue impacting the Amazon Buy Shipping service. Our development team is actively working on a fix to restore normal functionality. We will continue to provide updates as progress is made and will share additional information as soon as it becomes available.
Posted Jul 09, 2026 - 14:27 PDT

Update

We are continuing to investigate the issue affecting the Amazon Buy Shipping service. Our development team is actively working to determine the root cause and restore normal functionality. We will provide further updates as soon as more information becomes available.
Posted Jul 09, 2026 - 12:12 PDT

Investigating

We are currently investigating an issue where shipments cannot be created using Amazon Buy Shipping because the available Amazon Buy Shipping services are not allowing users to complete the shipping process. Our development team is actively working to identify the root cause and restore normal functionality. We will provide updates as soon as more information becomes available.
Posted Jul 09, 2026 - 11:25 PDT
This incident affected: Platform (Order Manager by Extensiv).