Billing Manager Down due to Billing Permissions Related Changes
Incident Report for Extensiv
Resolved
This incident has been resolved.
Posted Mar 01, 2024 - 08:37 PST
Update
Please consult this Help Article for assistance in updating roles as necessary.

https://help.extensiv.com/getting-started/add-billing-permission-to-a-role
Posted Feb 29, 2024 - 16:21 PST
Update
We updated Hub to include new Billing Manager permissions, which will require System Administrators to log out and log back in. If you’re not a system administrator and need to access Billing Manager, you need to contact your system administrator to update your permissions. You need “Billing Management admin access” or “Billing Management read-only access” to access Billing Manager.
Posted Feb 29, 2024 - 16:17 PST
Update
We are continuing to monitor for any issues. Please make sure to log out and back in if still experiencing this issue.
Posted Feb 29, 2024 - 16:08 PST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Feb 29, 2024 - 16:03 PST
Identified
The issue has been identified and a fix is being implemented.
Posted Feb 29, 2024 - 15:58 PST
This incident affected: Platform (Billing Manager).