Extensiv cannot be reached by phone

Incident Report for Extensiv

Resolved

This incident has been resolved.
Posted Apr 16, 2025 - 19:48 PDT

Investigating

Extensiv's phone provider is currently down so we are unable to receive or make calls at this time. Please reach out to your contacts via email. Support can also be reached by chat.
Posted Apr 16, 2025 - 12:58 PDT
This incident affected: Platform (3PL Warehouse Manager, SmartPack, Small Parcel Suite, SmartScan, Integration Manager by Extensiv, Order Manager by Extensiv, Warehouse Manager by Extensiv, Extensiv Hub, Support Portal, Billing Manager).