USPS Rate Shop Issue

Incident Report for Extensiv

Resolved

We have resolved the issue impacting USPS Rate Shopping. All functions are now fully operational.
Posted Sep 23, 2026 - 07:30 PDT

Investigating

We are currently investigating issues surrounding Small Parcel Rate Shopping with USPS accounts. This could impact any operation that involves Rate Shopping. We will provide an update within 1 hour.
Posted Sep 23, 2026 - 07:26 PDT
This incident affected: Platform (Small Parcel Suite).