Service Interruption

Incident Report for Extensiv

Resolved

This incident has been resolved.
Posted Nov 20, 2025 - 09:21 PST

Update

We are continuing to investigate this issue.
Posted Nov 20, 2025 - 09:21 PST

Investigating

We are currently investigation an incident with our cloud provider that is affecting the 3PL System. We will provide updates as they become available.
Posted Nov 20, 2025 - 09:09 PST
This incident affected: Platform (3PL Warehouse Manager, SmartPack, Small Parcel Suite, SmartScan).