Extensiv Help Center Intermittent Disruptions

Incident Report for Extensiv

Resolved

This incident has been resolved.
Posted Jun 10, 2025 - 13:53 PDT

Monitoring

Our Help Center provider, Helpjuice’s platform provider Heroku, is experiencing an issue that is causing our Help Center to intermittently slow down and timeout. See https://status.heroku.com/ for more details.

We will resolve this incident once we have received confirmation that the issue has been resolved from them.
Posted Jun 10, 2025 - 09:24 PDT
This incident affected: Web Properties (Extensiv Help Center).